快捷搜索:

您的位置:澳门新葡4473网站 > 澳门新葡4473网站 > CentOS编译安装emacs并配置

CentOS编译安装emacs并配置

发布时间:2019-11-14 16:37编辑:澳门新葡4473网站浏览(171)

    Liunxs中CentOS系列一向以稳定为目标,然而也会存在版本太旧的问题,emacs就是其中的一个,目前emacs都发行到25.2了,而CentOS上的emacs版本却还是23.1。所以需要下载源代码进行编译安装。

    • 澳门新葡4473网站,1.下载源代码并解压:
        sh-4.1$ wget http://mirrors.ustc.edu.cn/gnu/emacs/emacs-25.1.tar.gz 
        sh-4.1$ tar -xvf ~/emacs-25.1.tar.gz 
    

    具体下载情况请参考GNU Emacs。

    • 2.安装依赖库:
        sh-4.1$ sudo yum install gcc* glib* gtk* ncurses* libXpm* giflib* libjpeg* libtiff* libpng* -y
    
    • 3.编译链接:
        sh-4.1$ mkdir emacs_build      ## 防止污染源代码
        sh-4.1$ cd emacs_build/
        sh-4.1$ sudo ../emacs-25.1/configure
        sh-4.1$ sudo make && sudo make install
    
    • 4.查看结果:
        sh-4.1$ emacs --version
    

    就可以看到如下图所示结果:
    澳门新葡4473网站 1
    至此,emacs就安装完成了。然后就可以使用emacs的插件和配置了。

    配置详情请参考我GitHub上的emacs.d

    本文由澳门新葡4473网站发布于澳门新葡4473网站,转载请注明出处:CentOS编译安装emacs并配置

    关键词: